PT-2021-16086
CVE-2021-24569
·
تاريخ النشر
2021-09-27
·
تاريخ التحديث
2021-10-04
الوصف من
CVSS 3.1
4.8
متوسطةالمقاييسAV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Cookie Notice & Compliance for GDPR / CCPA WordPress plugin versions prior to 2.1.2
Description
The issue allows high privilege users, such as admins, to perform Cross-Site Scripting (XSS) attacks even when the unfiltered html capability is disallowed. This is due to the plugin not escaping the value of its Button Text setting when outputting it in an attribute in the frontend.
Recommendations
For versions prior to 2.1.2, update to version 2.1.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the Button Text setting to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾