PT-2021-16101

CVE-2021-24585

·

تاريخ النشر

2021-09-20

·

تاريخ التحديث

2021-10-01

الوصف من

CVSS 3.1
6.5
متوسطة
المقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions The Timetable and Event Schedule WordPress plugin versions prior to 2.4.0
Description The issue allows low-privilege users with the edit posts capability to retrieve sensitive user data, including hashed passwords, usernames, and email addresses, by requesting event Timeslot data and iterating over the user id. This can be combined with another issue where an arbitrary user ID can be set, potentially allowing unauthorized access to sensitive information.
Recommendations For versions prior to 2.4.0, update to version 2.4.0 or later to resolve the issue. As a temporary workaround, consider restricting the edit posts capability to high-privilege users until the update is applied. Restrict access to the event Timeslot data to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾