PT-2021-17758
CVE-2021-28125
·
تاريخ النشر
2021-04-27
·
تاريخ التحديث
2026-07-09
الوصف من
CVSS 3.1
6.1
متوسطةالمقاييسAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions:
Apache Superset versions prior to 1.1.0
Description:
The issue allows for the creation of an external URL that could be malicious. By not checking user input for open redirects, the URL shortener functionality would allow for a malicious user to create a short URL for a dashboard that could convince the user to click the link.
Recommendations:
For versions prior to 1.1.0, update to version 1.1.0 or later to resolve the issue. As a temporary workaround, consider disabling the URL shortener functionality until a patch is available. Restrict access to the URL shortener module to minimize the risk of exploitation. Avoid using the URL shortener functionality for dashboards until the issue is resolved.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾