PT-2021-18655

CVE-2021-30180

·

تاريخ النشر

2021-05-31

·

تاريخ التحديث

2022-03-18

الوصف من

CVSS 3.1
9.8
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Apache Dubbo versions prior to 2.7.9
Description The issue allows arbitrary constructors to be called when parsing YAML rules used for Tag routing. This routing is utilized by customers to direct requests to the appropriate server, relying on rules to find the correct endpoint.
Recommendations For versions prior to 2.7.9, update to version 2.7.9 or later to resolve the issue.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-7WFC-X4F7-GG2X
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾