PT-2021-18765

CVE-2021-30502

·

تاريخ النشر

2021-04-25

·

تاريخ التحديث

2021-05-07

الوصف من

CVSS 3.1
9.8
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions vscode-ghc-simple extension versions prior to 0.2.3
Description The issue allows remote code execution via a crafted workspace configuration with replCommand. This can be exploited by an attacker to execute malicious code.
Recommendations For versions prior to 0.2.3, update to version 0.2.3 or later to resolve the issue. As a temporary workaround, consider restricting the use of the replCommand in workspace configurations until the update is applied.
قابلية الاستغلال
إصلاح
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾