PT-2021-19935

CVE-2021-32793

·

تاريخ النشر

2021-08-04

·

تاريخ التحديث

2021-08-12

الوصف من

CVSS 3.1
5.7
متوسطة
المقاييسAV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:H
Name of the Vulnerable Software and Affected Versions Pi-hole Web Interface versions prior to 5.5.1
Description The Pi-hole Web interface has a stored cross-site-scripting vulnerability in the function to add domains to blocklists or allowlists. This vulnerability exists because user input added as a wildcard domain to a blocklist or allowlist is unfiltered in the web interface, allowing for a persistent XSS vulnerability. A remote attacker can attack administrative user accounts through client-side attacks.
Recommendations For versions prior to 5.5.1, update to Pi-hole Web Interface version 5.5.1 to resolve the issue. As a temporary workaround, consider restricting access to the blocklist and allowlist functions until the update is applied. Avoid using unfiltered user input as wildcard domains in blocklists or allowlists until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-G3W6-Q4FG-P8X8
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾