PT-2021-20317

CVE-2021-3377

·

تاريخ النشر

2021-03-05

·

تاريخ التحديث

2025-11-03

الوصف من

CVSS 3.1
6.1
متوسطة
المقاييسAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions: ansi up versions prior to 5.0.0
Description: The npm package ansi up is affected by a cross-site scripting (XSS) vulnerability due to insufficient URL sanitization when converting ANSI escape codes into HTML. This issue allows ANSI escape codes to create HTML hyperlinks.
Recommendations: For versions prior to 5.0.0, update to version 5.0.0 to resolve the issue. As a temporary workaround, consider disabling the feature that allows ANSI escape codes to create HTML hyperlinks until the update is applied.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-2V5F-23XC-V9QR
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾