PT-2021-21961

CVE-2021-38140

·

تاريخ النشر

2021-08-10

·

تاريخ التحديث

2021-08-17

الوصف من

CVSS 3.1
9.8
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions: PostgreSQL set user extension module versions prior to 2.0.1
Description: The issue allows a potential privilege escalation using RESET SESSION AUTHORIZATION after set user(). This can be exploited to gain elevated privileges.
Recommendations: For versions prior to 2.0.1, update to version 2.0.1 or later to resolve the issue. As a temporary workaround, consider restricting the use of the set user extension module until a patch is applied. Avoid using the RESET SESSION AUTHORIZATION command after set user() in the affected API endpoint until the issue is resolved.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾