PT-2021-22405
CVE-2021-39149
·
تاريخ النشر
2021-08-23
·
تاريخ التحديث
2026-10-07
الوصف من
CVSS 3.1
8.5
عاليةالمقاييسAV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
XStream versions prior to 1.4.18
Description
The issue allows a remote attacker to load and execute arbitrary code from a remote host by manipulating the processed input stream. This can be done when using affected versions of XStream, a library to serialize objects to XML and back again. Users who set up XStream's security framework with a whitelist limited to the minimal required types are not affected.
Recommendations
For versions prior to 1.4.18, update to version 1.4.18 or later, which uses a whitelist by default instead of a blacklist, to mitigate the risk of arbitrary code execution. As a temporary workaround, consider setting up XStream's security framework with a whitelist limited to the minimal required types to prevent exploitation.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾