PT-2021-2994

CVE-2021-29478

·

تاريخ النشر

2021-05-04

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 3.1
8.8
عالية
المقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Redis versions 6.2.0 through 6.2.2
Description The issue is related to an integer overflow bug that could be exploited to corrupt the heap and potentially result in remote code execution. This can be achieved by modifying the set-max-intset-entries configuration parameter. The problem can be mitigated by preventing users from modifying this parameter using ACL to restrict unprivileged users from using the CONFIG SET command.
Recommendations For Redis versions 6.2.0 through 6.2.2, update to version 6.2.3 to resolve the issue. As a temporary workaround, consider restricting access to the set-max-intset-entries configuration parameter by using ACL to prevent unprivileged users from using the CONFIG SET command.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-QH52-CRRG-44G3
MGASA-2021-0373
OESA-2021-1221
OPENSUSE-SU-2021:0682-1
OPENSUSE-SU-2021_0682-1
OPENSUSE-SU-2024:11299-1
SUSE-SU-2021:1652-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾