PT-2021-3108
CVE-2021-28662
·
تاريخ النشر
2021-05-10
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 2.0
7.8
عاليةالمقاييسAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
Squid versions 4.x through 4.14
Squid versions 5.x through 5.0.5
Description
An issue was discovered in Squid where a remote server can send a certain response header over HTTP or HTTPS, leading to a denial of service. This header can plausibly occur in benign network traffic. The vulnerability exists due to insufficient input validation when processing HTTP responses, allowing a remote attacker to cause a denial of service.
Recommendations
For Squid versions 4.x through 4.14, update to version 4.15 or later.
For Squid versions 5.x through 5.0.5, update to version 5.0.6 or later.
As a temporary workaround, consider restricting access to the HTTP and HTTPS protocols to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾