PT-2021-3347

CVE-2021-21702

·

تاريخ النشر

2021-02-08

·

تاريخ التحديث

2026-07-06

الوصف من

CVSS 2.0
7.8
عالية
المقاييسAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions PHP versions 7.3.x through 7.3.26 PHP versions 7.4.x through 7.4.14 PHP versions 8.0.x through 8.0.1
Description The issue is related to pointer dereference errors in the PHP SOAP extension. A malicious SOAP server could return malformed XML data, causing PHP to access a null pointer and resulting in a crash. This could allow a remote attacker to cause the application to terminate unexpectedly.
Recommendations For PHP versions 7.3.x through 7.3.26, update to version 7.3.27 or later. For PHP versions 7.4.x through 7.4.14, update to version 7.4.15 or later. For PHP versions 8.0.x through 8.0.1, update to version 8.0.2 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
ALSA-2021:4213
ALT-PU-2021-1297
ALT-PU-2021-1319
ALT-PU-2021-3079
ALT-PU-2021-3645
BIT-LIBPHP-2021-21702
BIT-PHP-2021-21702
BIT-PHP-MIN-2021-21702
CESA-2021_4213
CLSA-2024-1733429914
CLSA-2025-1748639500
DLA-2708-1
DSA-4856-1
MGASA-2021-0076
OPENSUSE-SU-2021:0305-1
OPENSUSE-SU-2021_0305-1
OPENSUSE-SU-2022_4067-1
OPENSUSE-SU-2022_4069-1
OPENSUSE-SU-2024:11569-1
RHSA-2021:2992
RHSA-2021:4213
RHSA-2021_4213
RLSA-2021:4213
SUSE-SU-2021:0494-1
SUSE-SU-2021_0494-1
SUSE-SU-2021:0498-1
SUSE-SU-2021_0498-1
SUSE-SU-2021:0522-1
SUSE-SU-2021_0522-1
SUSE-SU-2021:0584-1
SUSE-SU-2021_0584-1
SUSE-SU-2021:14668-1
SUSE-SU-2021_14668-1
SUSE-SU-2022:4067-1
SUSE-SU-2022:4068-1
SUSE-SU-2022:4069-1
USN-5006-1
USN-5006-2
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾