PT-2021-3389

CVE-2021-24376

·

تاريخ النشر

2021-06-21

·

تاريخ التحديث

2021-09-20

الوصف من

CVSS 3.1
9.8
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Autoptimize WordPress plugin versions prior to 2.7.8
Description The issue is related to the "Import Settings" feature of the Autoptimize WordPress plugin, which improperly handles the extraction of uploaded archives. This allows an attacker to upload a zip file containing a directory with a PHP file, bypassing the plugin's attempt to delete malicious files. The vulnerability enables remote code execution.
Recommendations For versions prior to 2.7.8, update to version 2.7.8 or later to resolve the issue. As a temporary workaround, consider disabling the "Import Settings" feature until a patch is available. Restrict access to the uploaded archives and extracted folders to minimize the risk of exploitation. Avoid using the "Import Settings" functionality with untrusted sources until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾