PT-2021-3436
CVE-2021-21043
·
تاريخ النشر
2021-02-02
·
تاريخ التحديث
2021-12-10
الوصف من
CVSS 2.0
10
عاليةالمقاييسAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
ACS Commons versions 4.9.2 and earlier
Description
The issue is related to a Reflected Cross-site Scripting (XSS) vulnerability in version-compare and page-compare due to invalid JCR characters that are not handled correctly. An attacker could potentially exploit this vulnerability to inject malicious JavaScript content into vulnerable form fields and execute it within the context of the victim's browser. Exploitation of this issue requires user interaction in order to be successful.
Recommendations
For ACS Commons versions 4.9.2 and earlier, update to version 4.10.0 to resolve the issue.
As a temporary workaround, consider restricting access to the version-compare and page-compare features until the update is applied.
Avoid using vulnerable form fields in these features until the issue is resolved.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾