PT-2021-3617

CVE-2021-36374

·

تاريخ النشر

2021-07-14

·

تاريخ التحديث

2026-10-15

الوصف من

CVSS 2.0
7.8
عالية
المقاييسAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions Apache Ant versions prior to 1.9.16 Apache Ant versions prior to 1.10.11
Description The issue is related to an uncontrolled resource consumption in Apache Ant. It can be exploited by a remote attacker to cause a denial of service. When Apache Ant reads a specially crafted ZIP archive or derived formats, it can allocate large amounts of memory, leading to an out of memory error, even with small inputs. This can disrupt builds using Apache Ant. Derived formats from ZIP archives, such as JAR files and many office files, are also affected.
Recommendations For Apache Ant versions prior to 1.9.16, update to version 1.9.16 or later. For Apache Ant versions prior to 1.10.11, update to version 1.10.11 or later.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-5V34-G2PX-J4FW
ALT-PU-2024-17640
AZL-25954
AZL-34809
CLEANSTART-2025-KO30612
CLSA-2026-1782225575
OESA-2021-1277
OPENSUSE-SU-2022_1418-1
OPENSUSE-SU-2024:11688-1
OPENSUSE-SU-2026:21891-1
SUSE-SU-2022:1417-1
SUSE-SU-2022:1418-1
SUSE-SU-2026:4677-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾