PT-2021-4105

CVE-2021-31155

·

تاريخ النشر

2021-03-17

·

تاريخ التحديث

2022-07-12

الوصف من

CVSS 3.1
7.8
عالية
المقاييسAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions pleaser versions prior to 0.4.0
Description The issue is related to a failure to normalize the umask in the please utility, which can allow a local attacker to gain full root privileges if they are allowed to execute at least one command. This can lead to unauthorized access to confidential data, disruption of data integrity, and denial of service.
Recommendations For versions prior to 0.4.0, update to version 0.4.0 or later to resolve the issue. As a temporary workaround, consider restricting the execution of commands that utilize the please utility to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-VC5P-J8VW-MC6X
RUSTSEC-2021-0101
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾