PT-2021-4407
CVE-2021-32687
·
تاريخ النشر
2021-10-04
·
تاريخ التحديث
2026-09-18
الوصف من
CVSS 3.1
7.5
عاليةالمقاييسAV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Redis versions prior to 5.0.14
Redis versions prior to 6.0.16
Redis versions prior to 6.2.6
Description
The issue is related to an integer overflow bug in Redis that can be exploited to corrupt the heap and potentially trigger remote code execution. This can be achieved by changing the default
set-max-intset-entries configuration parameter to a very large value and constructing specially crafted commands to manipulate sets.Recommendations
For versions prior to 5.0.14, update to version 5.0.14 or later.
For versions prior to 6.0.16, update to version 6.0.16 or later.
For versions prior to 6.2.6, update to version 6.2.6 or later.
As a temporary workaround, consider restricting unprivileged users from using the CONFIG SET command to prevent modification of the
set-max-intset-entries configuration parameter, which can be done using ACL. وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾