PT-2021-4600
CVE-2021-3518
·
تاريخ النشر
2021-04-22
·
تاريخ التحديث
2026-10-14
الوصف من
CVSS 3.1
8.8
عاليةالمقاييسAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
libxml2 versions prior to 2.9.11
Description
The issue is related to a use-after-free flaw in the xinclude.c component of the libxml2 library, which can be triggered by a specially crafted file. This can allow a remote attacker to access confidential data, compromise data integrity, and cause a denial of service. The flaw affects confidentiality, integrity, and availability.
Recommendations
For versions prior to 2.9.11, update to version 2.9.11 or later to resolve the issue.
As a temporary workaround, consider restricting the processing of crafted files by applications linked with libxml2 until a patch is available.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾