PT-2021-4613
CVE-2021-33620
·
تاريخ النشر
2021-05-28
·
تاريخ التحديث
2026-10-22
الوصف من
CVSS 3.1
6.5
متوسطةالمقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Squid versions prior to 4.15
Squid versions 5.x prior to 5.0.6
Description
The issue is related to insufficient input validation in the Squid proxy server, allowing a remote attacker to cause a denial of service, affecting availability to all clients. This can be triggered by an HTTP response with a header that can be expected to exist in HTTP traffic without any malicious intent by the server.
Recommendations
For Squid versions prior to 4.15, update to version 4.15 or later.
For Squid versions 5.x prior to 5.0.6, update to version 5.0.6 or later.
As a temporary workaround, consider restricting access to the HTTP response header that triggers the issue until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾