PT-2021-5535
CVE-2020-36221
·
تاريخ النشر
2021-01-25
·
تاريخ التحديث
2026-10-14
الوصف من
CVSS 2.0
7.8
عاليةالمقاييسAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
OpenLDAP versions prior to 2.4.57
Description
The issue is related to an integer underflow in the OpenLDAP implementation, which can be exploited by a remote attacker to cause a denial of service. This is achieved by sending a specially crafted request that triggers a crash in the Certificate Exact Assertion processing, specifically in the
serialNumberAndIssuerCheck function within schema init.c. The exploitation can result in the slapd service crashing.Recommendations
For versions prior to 2.4.57, update to version 2.4.57 or later to resolve the issue. As a temporary workaround, consider restricting access to the Certificate Exact Assertion processing to minimize the risk of exploitation.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾