PT-2021-6126
CVE-2022-25265
·
تاريخ النشر
2021-05-19
·
تاريخ التحديث
2026-10-18
الوصف من
CVSS 2.0
9.0
عاليةالمقاييسAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Linux kernel versions through 5.16.10
Description
The issue is related to a buffer overflow in the Linux kernel, which can be exploited by a remote attacker to execute arbitrary code. Certain binary files built around 2003, for example with GCC 3.2.2 and Linux kernel 2.4.20, may have the exec-all attribute, causing execution of bytes in supposedly non-executable regions of a file.
Recommendations
For Linux kernel versions through 5.16.10, update to a version later than 5.16.10 to resolve the issue. As a temporary workaround, consider restricting access to potentially vulnerable binary files built with older versions of GCC and the Linux kernel.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾