PT-2021-6878

CVE-2021-26271

·

تاريخ النشر

2021-01-26

·

تاريخ التحديث

2022-05-24

الوصف من

CVSS 2.0
7.1
عالية
المقاييسAV:N/AC:M/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions CKEditor 4 versions prior to 4.16
Description The issue is related to the inclusion of features from an untrusted controlled area in the Advanced Tab for Dialogs plugin of the CKEditor WYSIWYG editor. Exploitation of this issue could allow a remote attacker to spoof the contents of the address bar. It was possible to execute a ReDoS-type attack inside CKEditor 4 by persuading a victim to paste crafted text into the Styles input of specific dialogs in the Advanced Tab for Dialogs plugin.
Recommendations For CKEditor 4 versions prior to 4.16, update to version 4.16 or later to resolve the issue. As a temporary workaround, consider restricting access to the Styles input in the Advanced Tab for Dialogs plugin to minimize the risk of exploitation.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-JV4C-7JQQ-M34X
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾