PT-2021-7306
CVE-2021-41055
·
تاريخ النشر
2021-10-10
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 2.0
7.8
عاليةالمقاييسAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
Gajim versions 1.2.x through 1.3.2
Description
The issue is related to insufficient input validation when checking message IDs in multi-user chat, specifically with the XEP-0308 Last Message Correction extension. This allows remote attackers to cause a denial of service (crash) via a crafted XMPP message where the message ID equals the correction ID.
Recommendations
For Gajim versions 1.2.x through 1.3.2, update to version 1.3.3 or later to resolve the issue.
As a temporary workaround, consider disabling the XEP-0308 Last Message Correction extension in multi-user chat until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾