PT-2021-7397

CVE-2021-3935

·

تاريخ النشر

2021-11-01

·

تاريخ التحديث

2026-09-18

الوصف من

CVSS 3.1
8.1
عالية
المقاييسAV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions PgBouncer versions prior to 1.16.1
Description The issue is related to the handling of initial message request data in PgBouncer, which can be exploited by a remote attacker to access confidential data, compromise data integrity, and cause a denial of service. Specifically, when PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption.
Recommendations For versions prior to 1.16.1, update to version 1.16.1 or later to resolve the issue. As a temporary workaround, consider disabling the use of "cert" authentication in PgBouncer until a patch is available. Restrict access to the PgBouncer connection to minimize the risk of exploitation by a man-in-the-middle attacker.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALT-PU-2022-1238
ALT-PU-2022-2448
ALT-PU-2025-6618
BIT-PGBOUNCER-2021-3935
CLEANSTART-2026-DH31041
CLEANSTART-2026-MZ91907
DLA-2922-1
DLA-4180-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾