PT-2021-7543

CVE-2021-30354

·

تاريخ النشر

2021-09-01

·

تاريخ التحديث

2021-09-10

الوصف من

CVSS 2.0
9.3
عالية
المقاييسAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Amazon Kindle e-reader versions prior to and including 5.13.4
Description The issue is caused by an Integer Overflow in the CJBig2Image::expand() function, leading to a Heap-Based Buffer Overflow. This results in memory corruption and allows for code execution when a crafted PDF book is parsed. The vulnerability can be exploited by an attacker to execute arbitrary code using a specially crafted PDF file.
Recommendations For Amazon Kindle e-reader versions prior to and including 5.13.4, update to a version later than 5.13.4 to resolve the issue. As a temporary workaround, consider avoiding the use of crafted PDF books until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾