PT-2022-13430

CVE-2022-0776

·

تاريخ النشر

2022-03-01

·

تاريخ التحديث

2022-03-09

الوصف من

CVSS 3.1
6.1
متوسطة
المقاييسAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions hakimel/reveal.js versions prior to 4.3.0
Description The issue is related to Cross-site Scripting (XSS) - DOM. Specifically, the onmessage event listener in /plugin/notes/speaker-view.html does not check the origin of postMessage before adding the content to the webpage. This allows any origin to postMessage on the browser window and feed attacker's input to parts, which can execute arbitrary javascript code on the victim's browser window hosting reveal.js.
Recommendations For versions prior to 4.3.0, update to version 4.3.0 or later to resolve the issue. As a temporary workaround, consider disabling the onmessage event listener in /plugin/notes/speaker-view.html until a patch is available. Restrict access to the /plugin/notes/speaker-view.html module to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-HHQJ-CFJX-VJ25
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾