PT-2022-13891

CVE-2022-1440

·

تاريخ النشر

2022-04-22

·

تاريخ التحديث

2022-05-04

الوصف من

CVSS 2.0
10
حرجة
المقاييسAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions git-interface versions 2.1.1 through 2.1.1
Description A command injection issue exists in the git-interface. If both the git remote and destination directory are provided by user input, the use of a --upload-pack command-line argument feature of git is also supported for git clone, allowing any operating system command to be spawned by the attacker.
Recommendations For git-interface version 2.1.1, update to version 2.1.2 to resolve the issue. As a temporary workaround, consider restricting the use of the --upload-pack command-line argument feature of git for git clone until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-QFFW-8WG7-H665
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾