PT-2022-14076

CVE-2022-1726

·

تاريخ النشر

2022-05-16

·

تاريخ التحديث

2022-05-25

الوصف من

CVSS 3.1
6.8
متوسطة
المقاييسAV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:L
Name of the Vulnerable Software and Affected Versions bootstrap-table versions prior to 1.20.2
Description The issue allows for a XSS vulnerability with the Table Export plug-in when exportOptions: htmlContent is set to true. This can lead to disclosing session cookies, disclosing secure session data, and exfiltrating data to third-parties.
Recommendations For versions prior to 1.20.2, update to version 1.20.2 or later to resolve the issue. As a temporary workaround, consider setting exportOptions: htmlContent to false until a patch is applied. Restrict access to the Table Export plug-in to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-GRW5-G9H2-WPG8
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾