PT-2022-1455
CVE-2022-22817
·
تاريخ النشر
2022-01-02
·
تاريخ التحديث
2026-10-22
الوصف من
CVSS 2.0
10
حرجةالمقاييسAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Pillow versions prior to 9.0.1
Description
The issue allows evaluation of arbitrary expressions, such as ones that use the Python
exec method. A lambda expression could also be used, potentially enabling a remote attacker to execute arbitrary code in the system by passing a specially crafted file to the vulnerable library.Recommendations
For Pillow versions prior to 9.0.0, update to version 9.0.1 to resolve the issue.
For Pillow version 9.0.0, update to version 9.0.1 to fully restrict builtins available to lambda expressions and prevent exploitation.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾