PT-2022-14872
CVE-2022-2114
·
تاريخ النشر
2022-07-17
·
تاريخ التحديث
2022-07-18
الوصف من
CVSS 3.1
4.8
متوسطةالمقاييسAV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
The Data Tables Generator by Supsystic WordPress plugin versions prior to 1.10.20
Description
The issue allows high privilege users, such as admins, to perform Stored Cross-Site Scripting attacks when the unfiltered html capability is disallowed, for example in a multisite setup. This is due to the plugin not sanitizing and escaping some of its Table settings.
Recommendations
For versions prior to 1.10.20, update to version 1.10.20 or later to resolve the issue. As a temporary workaround, consider restricting the use of the Table settings feature to minimize the risk of exploitation. Additionally, ensure that the unfiltered html capability is properly configured to prevent Stored Cross-Site Scripting attacks.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾