PT-2022-16076

CVE-2022-23560

·

تاريخ النشر

2022-02-04

·

تاريخ التحديث

2026-07-09

الوصف من

CVSS 3.1
8.8
عالية
المقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions TensorFlow versions 2.5.3 through 2.7.1 TensorFlow version 2.8.0 is not affected, as it includes the fix.
Description An attacker can craft a TFLite model that would allow limited reads and writes outside of arrays in TFLite. This exploits missing validation in the conversion from sparse tensors to dense tensors.
Recommendations For TensorFlow versions 2.5.3, 2.6.3, and 2.7.1, upgrade to the respective patched versions as soon as possible. For TensorFlow versions prior to 2.8.0, upgrade to version 2.8.0 or later to resolve the issue. As a temporary workaround, consider restricting the use of TFLite models until a patch is applied.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-4HVF-HXVG-F67V
BIT-TENSORFLOW-2022-23560
OPENSUSE-SU-2024:12116-1
PYSEC-2022-124
PYSEC-2022-69
PYSEC-2026-3099
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾