PT-2022-16084

CVE-2022-23568

·

تاريخ النشر

2022-02-03

·

تاريخ التحديث

2026-07-09

الوصف من

CVSS 4.0
7.1
عالية
المقاييسAV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions TensorFlow versions prior to 2.8.0 TensorFlow versions 2.7.1 and earlier TensorFlow versions 2.6.3 and earlier TensorFlow versions 2.5.3 and earlier
Description The implementation of AddManySparseToTensorsMap is vulnerable to an integer overflow, resulting in a CHECK-fail when building new TensorShape objects. This can cause an assert failure-based denial of service. The issue is due to missing validation on the shapes of the input tensors and directly constructing a large TensorShape with user-provided dimensions.
Recommendations For versions prior to 2.8.0, update to TensorFlow 2.8.0 or later. For versions 2.7.1 and earlier, update to TensorFlow 2.7.1 or later. For versions 2.6.3 and earlier, update to TensorFlow 2.6.3 or later. For versions 2.5.3 and earlier, update to TensorFlow 2.5.3 or later. As a temporary workaround, consider disabling the AddManySparseToTensorsMap function until a patch is available. Restrict access to the TensorShape constructor to minimize the risk of exploitation. Avoid using user-provided dimensions when constructing TensorShape objects until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-6445-FM66-FVQ2
BIT-TENSORFLOW-2022-23568
OPENSUSE-SU-2024:12116-1
PYSEC-2022-132
PYSEC-2022-77
PYSEC-2026-3114
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾