PT-2022-16910

CVE-2022-24832

·

تاريخ النشر

2022-04-11

·

تاريخ التحديث

2022-04-19

الوصف من

CVSS 3.1
8.2
عالية
المقاييسAV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
Name of the Vulnerable Software and Affected Versions GoCD versions prior to 22.1.0
Description The issue affects the gocd-ldap-authentication-plugin bundled with the GoCD Server, which fails to correctly escape special characters when using the username to construct LDAP queries. This allows an existing LDAP-authenticated GoCD user with malicious intent to construct and execute malicious queries, enabling them to deduce facts about other users or entries within the LDAP database through brute force mechanisms. The issue only affects users with a working LDAP authorization configuration enabled on their GoCD server and is exploitable by users authenticating using such an LDAP configuration.
Recommendations For versions prior to 22.1.0, update to GoCD 22.1.0, which is bundled with gocd-ldap-authentication-plugin v2.2.0-144, to resolve the issue. As a temporary workaround, consider restricting access to the LDAP authentication configuration to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-X5V3-X9QJ-MH3H
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾