PT-2022-17007

CVE-2022-24950

·

تاريخ النشر

2022-08-16

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 3.1
7.5
عالية
المقاييسAV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Eternal Terminal versions prior to 6.2.0
Description A race condition exists in the software that allows an authenticated attacker to hijack other users' SSH authorization socket, enabling the attacker to login to other systems as the targeted users. The bug is in the getInfoForId() function of UserTerminalRouter.
Recommendations For versions prior to 6.2.0, update to version 6.2.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the UserTerminalRouter::getInfoForId() function until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-85GW-PCHC-4RF3
OPENSUSE-SU-2022:10185-1
OPENSUSE-SU-2022:10187-1
OPENSUSE-SU-2024:12269-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾