PT-2022-17216

CVE-2022-25328

·

تاريخ النشر

2022-02-25

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 3.1
7.3
عالية
المقاييسAV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions fscrypt versions prior to 0.3.3
Description The bash completion script for fscrypt allows injection of commands via crafted mountpoint paths, allowing privilege escalation under a specific set of circumstances. A local user who has control over mountpoint paths could potentially escalate their privileges if they create a malicious mountpoint path and if the system administrator happens to be using the fscrypt bash completion script to complete mountpoint paths.
Recommendations For versions prior to 0.3.3, upgrade to version 0.3.3 or above. As a temporary workaround, consider restricting the use of the fscrypt bash completion script to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-WXJG-P59J-6C92
ALT-PU-2023-1941
OPENSUSE-SU-2024:11902-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾