PT-2022-17567

CVE-2022-25850

·

تاريخ النشر

2022-05-01

·

تاريخ التحديث

2022-05-11

الوصف من

CVSS 3.1
7.5
عالية
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions github.com/hoppscotch/proxyscotch versions prior to 1.0.0
Description The issue occurs when an HTTP request is made by a backend server to an untrusted URL submitted by a user, leading to a leakage of sensitive information from the server. This happens when the interceptor mode is set to proxy.
Recommendations For versions prior to 1.0.0, update to version 1.0.0 or later to resolve the issue. As a temporary workaround, consider disabling the proxy interceptor mode until a patch is available. Restrict access to untrusted URLs to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-5HJH-C26M-XW8W
SNYK-GOLANG-GITHUBCOMHOPPSCOTCHPROXYSCOTCH-2435228
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾