PT-2022-1907
CVE-2022-24407
·
تاريخ النشر
2022-02-22
·
تاريخ التحديث
2026-10-14
الوصف من
CVSS 2.0
9.4
عاليةالمقاييسAV:N/AC:L/Au:N/C:C/I:C/A:N
Name of the Vulnerable Software and Affected Versions
Cyrus SASL versions 2.1.17 through 2.1.27
Description
The issue is related to the implementation of the authentication mechanism in Cyrus SASL, where the SQL query structure is not properly protected. This could allow a remote attacker to execute arbitrary SQL queries. The problem lies in the plugins/sql.c file, which does not escape the password for SQL INSERT or UPDATE statements.
Recommendations
For Cyrus SASL versions 2.1.17 through 2.1.27, update to version 2.1.28 or later to resolve the issue. As a temporary workaround, consider restricting access to the
plugins/sql.c file or disabling the SQL authentication mechanism until a patch is applied. Avoid using the password variable in SQL INSERT or UPDATE statements until the issue is resolved. وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾