PT-2022-20505

CVE-2022-31070

·

تاريخ النشر

2022-06-15

·

تاريخ التحديث

2022-07-05

الوصف من

CVSS 3.1
7.5
عالية
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions @finastra/nestjs-proxy versions prior to 0.7.0 @ffdc/nestjs-proxy (affected versions not specified)
Description The nestjs-proxy library did not have a way to block sensitive cookies, such as session cookies, from being forwarded to backend services configured by the application developer. This could have led to sensitive cookies being inadvertently exposed to such services that should not see them. The patched version now blocks cookies from being forwarded by default, but developers can configure an allow-list of cookie names by using the allowedCookies config setting.
Recommendations For @finastra/nestjs-proxy versions prior to 0.7.0, update to version 0.7.0 to fix the issue. For @ffdc/nestjs-proxy users, update the package.json file to use @finastra/nestjs-proxy instead, as @ffdc/nestjs-proxy has been deprecated and is no longer being maintained or receiving updates.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-77MV-4RG7-R8QV
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾