PT-2022-20539

CVE-2022-31115

·

تاريخ النشر

2022-06-30

·

تاريخ التحديث

2022-07-25

الوصف من

CVSS 3.1
8.8
عالية
المقاييسAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions opensearch-ruby versions prior to 2.0.1
Description The issue is related to the use of the ruby YAML.load function instead of YAML.safe load in opensearch-ruby, which can lead to unsafe deserialization using YAML.load if the response is of type YAML. An attacker must be in control of an opensearch server and convince the victim to connect to it in order to exploit this vulnerability.
Recommendations For versions prior to 2.0.1, upgrade to version 2.0.1 or later to resolve the issue. As a temporary workaround, consider avoiding the use of YAML responses until the issue is resolved. Restrict access to opensearch servers to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-977C-63XQ-CGW3
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾