PT-2022-20556

CVE-2022-31136

·

تاريخ النشر

2022-07-07

·

تاريخ التحديث

2022-07-15

الوصف من

CVSS 3.1
6.3
متوسطة
المقاييسAV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions Bookwyrm versions prior to 0.4.1
Description The issue concerns an open source social reading and reviewing program where versions prior to 0.4.1 did not properly sanitize HTML being rendered to users. Unprivileged users can inject scripts into user profiles, book descriptions, and statuses, potentially leading to cross-site scripting attacks on users viewing these fields.
Recommendations For versions prior to 0.4.1, upgrade to version 0.4.1 to resolve the issue. As a temporary workaround, consider restricting access to user profiles, book descriptions, and statuses until the upgrade is applied. Avoid using the affected fields in the program until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-2CFH-V7RF-PXFP
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾