PT-2022-2058

CVE-2022-0759

·

تاريخ النشر

2022-02-24

·

تاريخ التحديث

2022-04-07

الوصف من

CVSS 3.1
8.1
عالية
المقاييسAV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions kubeclient versions prior to 4.9.3
Description The issue is related to errors in the certificate authentication procedure of the Kubeclient::Config class in the Kubernetes REST API client. This can allow a remote attacker to perform a Man-in-the-middle (MITM) attack. The problem arises when the kubeconfig file does not configure a custom CA to verify certificates, causing kubeclient to accept any certificate.
Recommendations For versions prior to 4.9.3, update to version 4.9.3 or later to resolve the issue. As a temporary workaround, consider configuring a custom CA to verify certificates in the kubeconfig file to minimize the risk of exploitation. Restrict access to sensitive resources until the update is applied.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-69P3-XP37-F692
RHSA-2023:6818
RLSA-2023:6818
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾