PT-2022-2733

CVE-2022-1785

·

تاريخ النشر

2022-05-16

·

تاريخ التحديث

2025-03-30

الوصف من

CVSS 3.1
7.8
عالية
المقاييسAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions vim versions prior to 8.2.4977
Description The issue is related to an out-of-bounds write in the vim regsub both() function of the Vim text editor, which can be exploited by an attacker to execute arbitrary code or cause a denial of service using a specially crafted file. The vulnerability is associated with a buffer overflow error when processing untrusted input data.
Recommendations For versions prior to 8.2.4977, update to version 8.2.4977 or later to resolve the issue. As a temporary workaround, consider restricting the use of the vim regsub both() function until a patch is available. Avoid opening specially crafted files that may trigger the vulnerability.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
ALSA-2022:5813
ALSA-2022_5813
ALSA-2022:5942
ALSA-2022_5942
ALT-PU-2022-1948
ALT-PU-2022-1958
ALT-PU-2022-1977
ALT-PU-2022-1987
AZL-9790
CESA-2022_5813
DLA-3204-1
DLA-4097-1
OESA-2022-1699
OPENSUSE-SU-2022_2102-1
OPENSUSE-SU-2024:12337-1
RHSA-2022:5813
RHSA-2022_5813
RHSA-2022:5942
RHSA-2022_5942
RLSA-2022:5813
RLSA-2022:5942
SUSE-SU-2022:2102-1
SUSE-SU-2022:4619-1
USN-5498-1
USN-5995-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾