PT-2022-3318

CVE-2022-2284

·

تاريخ النشر

2022-07-02

·

تاريخ التحديث

2026-10-23

الوصف من

CVSS 3.1
7.8
عالية
المقاييسAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions vim versions prior to 9.0
Description The issue is related to a heap-based buffer overflow in the utfc ptr2len() function of the Vim text editor. This can allow an attacker to impact the confidentiality, integrity, and availability of protected information.
Recommendations For versions prior to 9.0, update to version 9.0 or later to resolve the issue. As a temporary workaround, consider restricting the use of the utfc ptr2len() function until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
ALT-PU-2022-2600
ALT-PU-2022-2637
ALT-PU-2022-2659
ALT-PU-2022-3192
AZL-10014
CLSA-2026-1777477742
CLSA-2026-1787917228
CLSA-2026-1792153017
MGASA-2022-0430
OESA-2022-1749
OPENSUSE-SU-2022_3229-1
OPENSUSE-SU-2024:12337-1
SUSE-SU-2022:3229-1
SUSE-SU-2022:4619-1
USN-6270-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾