PT-2022-3445
CVE-2022-2000
·
تاريخ النشر
2022-06-07
·
تاريخ التحديث
2026-10-23
الوصف من
CVSS 3.1
7.8
عاليةالمقاييسAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Vim versions prior to 8.2
Description
The issue is related to an out-of-bounds write in the Vim text editor, specifically in the
append command() function. This could allow a remote attacker to execute arbitrary code.Recommendations
For versions prior to 8.2, update to version 8.2 or later to resolve the issue. As a temporary workaround, consider restricting the use of the
append command() function until a patch is available.قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾