PT-2022-3497

CVE-2022-33980

·

تاريخ النشر

2022-07-06

·

تاريخ التحديث

2025-09-29

الوصف من

CVSS 3.1
9.8
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Apache Commons Configuration versions 2.4 through 2.7
Description The issue is related to the variable interpolation feature in Apache Commons Configuration, which allows properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. The affected versions include default Lookup instances that could result in arbitrary code execution or contact with remote servers, specifically the "script", "dns", and "url" lookups. These lookups can execute expressions using the JVM script execution engine, resolve DNS records, and load values from URLs, including from remote servers. Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used.
Recommendations Upgrade to Apache Commons Configuration 2.8.0, which disables the problematic interpolators by default. As a temporary workaround, consider disabling the "script", "dns", and "url" lookups to minimize the risk of exploitation. Restrict access to untrusted configuration values to prevent potential remote code execution or unintentional contact with remote servers.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-XJ57-8QJ4-C4M6
ALSA-2025_16880
DSA-5290-1
OPENSUSE-SU-2024:13259-1
RHSA-2023:2097
RLSA-2023:2097
RLSA-2023_2097
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾