PT-2022-4784
CVE-2022-23853
·
تاريخ النشر
2022-02-11
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 2.0
10
عاليةالمقاييسAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
KDE Kate versions prior to 21.12.2
KTextEditor versions prior to 5.91.0
Description
The issue is related to insufficient input validation in the Language Server Protocol plugin. This can allow a remote attacker to access confidential data, compromise its integrity, and cause a denial of service. The plugin tries to execute the associated LSP server binary when opening a file of a given type. If the binary is absent from the PATH, it will attempt to run the LSP server binary in the directory of the file that was just opened, which can be an untrusted directory due to a misunderstanding of the QProcess API.
Recommendations
For KDE Kate versions prior to 21.12.2, update to version 21.12.2 or later to resolve the issue.
For KTextEditor versions prior to 5.91.0, update to version 5.91.0 or later to resolve the issue.
As a temporary workaround, consider restricting access to untrusted directories to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾