PT-2022-4855
CVE-2022-0554
·
تاريخ النشر
2022-01-10
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 2.0
9.3
عاليةالمقاييسAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Vim versions prior to 8.2
Description
The issue is related to the
enter buffer() function in the Vim text editor, which is associated with an out-of-bounds pointer offset. This allows a remote attacker to access confidential data, compromise its integrity, and cause a denial of service. The estimated number of potentially affected devices worldwide is not specified.Recommendations
For versions prior to 8.2, update to version 8.2 or later to resolve the issue. As a temporary workaround, consider restricting the use of the
enter buffer() function until a patch is available. وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾