PT-2022-4856

CVE-2022-0685

·

تاريخ النشر

2022-02-19

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 2.0
9.3
عالية
المقاييسAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Vim versions prior to 8.2.4418
Description The issue is related to the incorrect handling of a special multibyte character in the unix expandpath() function of the Vim text editor. This allows a remote attacker to access confidential data, compromise its integrity, and cause a denial of service. The problem is associated with the use of an out-of-range pointer offset.
Recommendations For versions prior to 8.2.4418, update to version 8.2.4418 or later to resolve the issue. As a temporary workaround, consider restricting the use of the unix expandpath() function until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
ALT-PU-2022-1693
ALT-PU-2022-1711
ALT-PU-2022-1731
ALT-PU-2022-1771
AZL-8677
DLA-2947-1
DLA-3182-1
MGASA-2022-0203
OESA-2022-1580
OPENSUSE-SU-2024:12337-1
USN-5460-1
USN-6026-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾