PT-2022-4977
CVE-2022-3296
·
تاريخ النشر
2022-09-22
·
تاريخ التحديث
2026-10-16
الوصف من
CVSS 3.1
7.8
عاليةالمقاييسAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Vim versions prior to 9.0.0577
Description
The issue is related to a stack-based buffer overflow in the ex finally() function of the Vim text editor. Exploitation of this issue may allow an attacker to cause a denial of service or execute arbitrary code using a specially crafted file.
Recommendations
For versions prior to 9.0.0577, update to version 9.0.0577 or later to resolve the issue. As a temporary workaround, consider restricting the use of the ex finally() function until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾