PT-2022-4994
CVE-2022-40956
·
تاريخ النشر
2022-09-20
·
تاريخ التحديث
2024-12-12
الوصف من
CVSS 2.0
6.4
متوسطةالمقاييسAV:N/AC:L/Au:N/C:P/I:P/A:N
Name of the Vulnerable Software and Affected Versions
Firefox versions prior to 105
Firefox ESR versions prior to 102.3
Thunderbird versions prior to 102.3
Description
The issue is related to an incorrect restriction of visualizable layers or frames in the user interface when handling HTML elements, specifically with the implementation of the Content Security Policy (CSP)
base-uri directive in browsers. This can allow a remote attacker to bypass security restrictions by injecting an HTML base element, which some requests would accept instead of the CSP's base-uri settings.Recommendations
For Firefox versions prior to 105, update to version 105 or later to resolve the issue.
For Firefox ESR versions prior to 102.3, update to version 102.3 or later to resolve the issue.
For Thunderbird versions prior to 102.3, update to version 102.3 or later to resolve the issue.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾